Fix issues related to products not displaying on the online menu.

Dutchie Ecommerce Troubleshooting Guide: Products not displaying on the online menu 

This article will guide you through possible causes and solutions for products not displaying on the online menu.

Before you begin

If the above articles do not help you solve the problem, follow these troubleshooting steps below:

Problem

  • Products not displaying on the online menu
  • Display issues with Products in Ecommerce
  • Configured item as available in Dutchie POS, but it doesn’t appear on the online menu
  • Brands, items, inventory, or categories not showing up on the online menu

Causes

Several factors can impact whether products are displayed on your online menu. These include:

  • Syncing Delays - Menus sync automatically every 10-20 minutes. There might be a delay in the sync process.
  • Room Configuration - Ecommerce room configuration needs to be enabled for the product to display on Ecommerce. 
  • Low Inventory Thresholds - Low inventory thresholds may be set too high. This setting can be adjusted from within each product page in the Catalog.
  • Quantity Thresholds - When the quantity shown in Dutchie POS is less than or equal to the quantity threshold the Quantity Threshold may need to be readjusted.
  • Category Mapping - Categories need to be properly represented during the configuration process in Dutchie Admin for products to show online. 

Solutions

Step 1: Check Sync Status

  • Allow enough time for the automatic sync to occur, if issues persist move on to the next troubleshooting steps.

Step 2: Quantity Threshold 

  • Ensure that the items are not below the quantity threshold.
  • From your Dutchie Ecommerce admin page, go to  Settings > Integrations.
  • Click on your active POS integration.
  • Click the Settings tab.
  • Scroll down to the Quantity Thresholds section, and click Edit within that category.

  • Select a quantity from the drop-down menu(s). 

  • After editing all thresholds, click Save.

Step 3: Low Inventory Threshold 

  • Check the product catalog in Dutchie POS, on the ‘details page’, and review the low inventory threshold field.
  • Review the ‘location detail’ page and check the low inventory threshold for the impacted location.

Step 4: Verify “Available Online”

  • Check that the items are set to show online in the ‘Online Details’ tab in the Product Catalog.

Step 5: Room Configuration 

  • Navigate to Dutchie POS Rooms and select the room tied to your online menu.
  • Ensure that ‘Ecommerce Room’ is turned on.

Step 6: Category Configuration

  • Confirm that the items are assigned to the correct category. You can find this at Settings > Integrations > Point of Sale > Categories at admin.dutchie.com.
  • All categories must be mapped to reflect associated products on the online menu.

Step 7: Manually Trigger Sync

  • Move the items from the sales floor to a different room.
  • Move the items back to the sales floor, this will manually trigger a resync of this product. 
  • Allow 10-20 minutes for Menu Sync to occur.
  • Confirm Display on Online Menu. Check the online menu to confirm if the items are now visible.

If these troubleshooting steps do not solve your issue, contact Dutchie Support. 

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