Troubleshoot Metrc inventory adjustment failure in Dutchie POS
This article applies to Dutchie POS.
Troubleshoot Metrc inventory adjustments in Dutchie POS including discrepancies and failed or missing API keys.
Having trouble with Metrc inventory adjustments? Read on to learn about common issues and how to troubleshoot a failed inventory adjustment.
Cause
The cause of your failed inventory adjustment is typically related to:
- Master API Key has failed
- User API Key has failed or is missing entirely (workflow specific)
- Discrepancies in Dutchie and Metrc
What is an API?
API is the acronym for application programming interface — a software connection that allows two applications to talk to each other. APIs are an accessible way to extract and share data within and across organizations. Dutchie’s Application Programming Interface (API) provides the underlying framework for developing applications and custom integrations between Dutchie and other software. Via the Dutchie API connection partners such as Metrc can get, post, or update information about their sales, returns, inventory levels/adjustments, etc. in real-time.
Solution
First, you’ll need to identify the root cause of the inventory adjustment issue, by reproducing the issue:
- Check if the Master API Key has failed
- Confirm if the user API Key is missing or failed (workflow specific) check the individual user key requirements
Validate Master API Key
- Go to Settings > integrations > Metrc > Validate Key.
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- If the Master API Key column shows success with API endpoints, it is valid and you’ll need to troubleshoot the Metrc user API Key.
- If not, request the Admin that holds that key to regenerate the API key in Metrc and paste in the Master API Key in Dutchie POS.
Validate user Key
When dealing with issues related to the adjustment reason not populating, you will need to update your individual METRC API key. You can check the validity of your API key by navigating to:
- Go to Settings > Integrations > Metrc > User keys.
- Confirm that the issue is affecting users with incorrect or missing key assignments.
- Add an individual user API key to the profile having issues.
Note: This can be found in Metrc, regenerate API key in Metrc and paste in the Dutchie POS user key. - Once the key is added to the user, verify that the issue is resolved by having the user attempt to submit an adjustment on inventory again.
Validate Permissions
- Verify your permissions. To validate, Go to Settings > Integrations > Metrc > Validate key, see Update your Metrc API Key.
Validate Dutchie and Metrc quantities
When submitting adjustments to Metrc, adjustments are not communicated to the state if they already have the desired quantity levels in Metrc.
Example: Let’s say Dutchie has a quantity level of 11 and Metrc has a quantity of 10. When the adjustment is processed in Dutchie to reduce to 10, it will reflect in Dutchie that an adjustment was made. However, the adjustment will not reflect in Metrc because Metrc already has the quantity level of 10. Even though the adjustment is not reflected, users don't get any errors or warnings due to it working as designed.
If you notice adjustments are not pushing through to Metrc, please confirm if the quantity levels in Metrc already match the desired quantity. If the quantity in Metrc does not match the adjusted quantity levels in Dutchie, please contact support.
Note!
If the above steps do not resolve the issue, escalate it to Dutchie Support for further investigation.
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