Learn what to do when a percent-off discount takes off an unexpected amount at checkout.
Problem
When creating a manual discount intended to take a percent off each item, the discount displays an incorrect amount at checkout.
Note that percent-off discounts are represented in Dutchie E-Commerce and in the Register as a calculated dollar amount rather than a percentage. This is expected behavior. For example, a 20% discount on a $10 item will appear as $2.00 off.
Cause
This may be because you have the Round Percent Discounts setting enabled, or due to an unintended selection in the Apply reward to field in the discount configuration.
Solution
First, in the Dutchie Backoffice, go to Settings > Location and find the Round Percent Discounts setting. If enabled, percent-off discounts amounts will be rounded to the nearest dollar, which can result in unexpected discount amounts. Turn this setting off if you want to apply exact percentage discounts.
Next, go to Marketing > Discounts and select the discount that isn't applying the way you expect it to. In the Rewards section, in the How will it be applied section, choose the desired option for Apply reward to:
- Just one item means that if the cart contains more than one unit of the same eligible product, the discount applies only to the first unit.
- Each item in row means the discount applies to each unit of an eligible product. This is typically the how users intend their percentage discounts to apply.
- Apply to subtotal means the percentage is calculated against the subtotal of all eligible products, and then the resulting discount amount is distributed proportionally across the eligible line items. For a percentage discount, the end result is mathematically the same as "Each item in row" — the distinction matters more for dollar-amount discounts or when applying a manual percent-off discount at the cart level as opposed to line-item level.