Learn how to troubleshoot log in conflicts with Wix and Google Accounts.
Troubleshoot the embedded Wix menu and log in issues with Google Account
Customers may encounter an error while trying to log on to your embedded menu when using their Google Account: "Server error, please try again later." The URL may not work for them, or they may have issues logging into the cart, checking out, etc.
This typically happens with Wix hosted sites due to differences between the domain configurations and how pages are linked or loaded. Specifically, if the URL structure or hostname changes between the Wix site’s homepage and linked pages, it can trigger issues with Cross-Origin Resource Sharing (CORS) policies, and cause Google Sign-On to fail.
Common Causes
Different URL Structures
When a user navigates a Wix site, ensure that links do not open in a new tab with a different URL structure or hostname than the original domain.
For Example: If the homepage URL is example.com and clicking “Shop Now” opens store.example.com in a new tab, the difference in the domain or subdomain can break Google Sign-On.
Open storefronts in new tabs
If a link opens in a new tab with a different hostname or URL structure, it can trip the CORS check.
We’ve added some code to address this, but it’s still recommended to not activate this setting on Wix
Policies that restrict access to different origins to prevent security risks, so loading pages with a different origin can block Google Sign-On.
iFrame/Embedded menu
Google Sign-On does not always work when the site uses iFrames from different origins. Browsers block scripts from accessing iFrames with a different origin due to the same-origin policy, as this would be a security vulnerability.
Solutions
- Disable opening new links and storefronts in separate tabs
- Ensure the storefront and the hosted Wix site share the same hostname and URL base domain.