Whether you want to display your entire menu or sections of your menu using custom carousels on your website, you'll need to generate the appropriately formatted embed scripts in Dutchie ECommerce.
With Dutchie Ecommerce it is possible to embed your full dispensary menu and customer carousels on your website. These menus can function in different ways from a standard menu that allows customers to order normally to a view-only menu where customers can view products before purchasing in-store.
Things to know
- Before embedding homepage sections, you need to define sections in Customize > Homepage. Only sections that have been created on your homepage can be embedded.
- For best results, make sure that the embed code for homepage sections is added in as its own row.
- The Product Support team at Dutchie Ecommerce will be notified when the embed script is added to your website. The team will review it and add any styling to ensure it is full-width and responsive.
- Shopify users need to generate the script and then embed it in their Shopify page; reach out to Shopify support if you have questions about making changes to your Shopify account.
Embed your full menu
You can embed a full menu of all of your dispensary's offerings. This usually appears as its own page.
- After logging into your Dutchie Ecommerce Admin, go to Customize > Embed.
- In the Embed your Menu area, choose the Menu Type.
- Copy the embed script to add to your website.
Menu types
- Standard Menu: The standard, default Dutchie Ecommerce menu. This menu is recommended for most dispensaries.
- View only: Offers full browsing functionality. Items cannot be added to the cart, eliminating all ordering functionality. This allows customers to browse the menu, but they won't be able to add items to their cart or place orders. Note: If you only want to pause ordering temporarily see: Temporarily pause orders on Dutchie Ecommerce.
- Recreational Menu: Automatically defaults to your Recreational menu. Recommended when utilizing separate pages on your site for recreational and medical menus.
- Medical Menu: Automatically defaults to your Medical menu. Recommended when utilizing separate pages on your site for recreational and medical menus.
- Multi-location Selector: For dispensaries that have multiple locations. This option will allow customers to type their address and find the nearest location.
- Dynamic Delivery: For delivery operations that have multiple locations (the “Ice cream truck model”). This option asks the customer for their address and then takes them to the nearest location that can deliver to them.
Embed homepage sections
You can display a section of your menu, like a category, Staff Picks, or Popular items. This often appears as a full-width row on an existing webpage.
- After logging into your Dutchie Ecommerce Admin, go to Customize > Embed.
- In the Embed Homepage Sections area, choose the section to embed from the dropdown.
- Choose whether to include the Title and/or View All link in the embed script.
- Enter your website URL.
- Copy the embed script to add to your website.
Troubleshooting the embedded Wix menu and log in issues with Google Account
Customers may encounter an error while trying to log on to your embedded menu when using their Google Account: "Server error, please try again later." The URL may not work for them, or they may have issues logging into the cart, checking out, etc.
This typically happens with Wix hosted sites due to differences between the domain configurations and how pages are linked or loaded. Specifically, if the URL structure or hostname changes between the Wix site’s homepage and linked pages, it can trigger issues with Cross-Origin Resource Sharing (CORS) policies, and cause Google Sign-On to fail.
Common Causes
Different URL Structures
When a user navigates a Wix site, ensure that links do not open in a new tab with a different URL structure or hostname than the original domain.
For Example: If the homepage URL is example.com and clicking “Shop Now” opens store.example.com in a new tab, the difference in the domain or subdomain can break Google Sign-On.
Open storefronts in new tabs
If a link opens in a new tab with a different hostname or URL structure, it can trip the CORS check.
We’ve added some code to address this, but it’s still recommended to not activate this setting on Wix
Policies that restrict access to different origins to prevent security risks, so loading pages with a different origin can block Google Sign-On.
iFrame/Embedded menu
Google Sign-On does not always work when the site uses iFrames from different origins. Browsers block scripts from accessing iFrames with a different origin due to the same-origin policy, as this would be a security vulnerability.
Solutions
- Disable opening new links and storefronts in separate tabs
- Ensure the storefront and the hosted Wix site share the same hostname and URL base domain.